Задать вопрос

Заполнить массив 10 случайными числами от 1 до 10. Проверить сколько чисел будет больше числа А (задается с клавиатуры.)

+3
Ответы (1)
  1. 11 октября, 01:11
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, A, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write (' введите заданное число ');

    read (A);

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (10) + 1;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] > A then k:=k + 1;

    writeln (' элементов больших заданного = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Заполнить массив 10 случайными числами от 1 до 10. Проверить сколько чисел будет больше числа А (задается с клавиатуры.) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Заполнить массив из 15 элементов целыми случайными числами из диапазона от 0 до 40. Вывести массив на экран и найти сумму элементов массива, минимальный элемент массива и количество чисел больше 10
Ответы (1)
Напишите программу, которая заполняет массив случайными целыми числами, вводит с клавиатуры целое число N и копирует в новый массив все числа из исходного массива, для которых сумма значений всех цифр равна N.
Ответы (1)