Задать вопрос

1. замените слово "мама" на "папа" (в паскале) 2. Определите является ли текст перевертышем (например, как слово шалаш) (тоже паскаль)

+4
Ответы (1)
  1. 7 февраля, 14:43
    0
    program zz1;

    var s1, s2:string;

    i:integer;

    begin

    write ('введите строку '); / /вводим исходную строку

    read (s1);

    for i:=1 to length (s1) do / /перебираем все буквы строки от первой до последней

    if copy (s1, i, 4) = 'мама' then begin delete (s1, i, 4); insert ('папа', s1, i); end; / /копируем из строки по 4 буквы, сравниваем с "мама", если совпадает, то удаляем их и вставляем на то же место "папа"

    writeln (s1); / /выводим ответ

    for i:=length (s1) downto 1 do / /перебираем все буквы строки от последней до первой

    s2:=s2+s1[i]; / /получаем перевернутую строку

    if s1=s2 then write ('перевертыш') else write ('не перевертыш'); / /сравниваем две строки, если совпадают, то "перевертыш", если нет, то нет.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. замените слово "мама" на "папа" (в паскале) 2. Определите является ли текст перевертышем (например, как слово шалаш) (тоже паскаль) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано слово. Проверить является ли оно ''перевертышем'' (перевертышем называется слово, читаемое одинакого как с начала так и с конца),
Ответы (1)
Составьте программу, выясняющую, является ли данное слово перевертышем (так называются слова, читвющиеся одинаково слева направо и справа налево, например: топот, шалаш)
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)
Сравни (отметь). а) Чем похожа библиотека на компьютерную сеть Интернет? Тоже можно найти документ; Носитель информации - тоже бумага; Данные тоже можно найти по фамилии автора; Данные тоже можно найти по ключевому слову;
Ответы (2)
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)