Задать вопрос

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем. (a=0 признак окончания ввода, ноль не входит в последовательность). Программа должна вывести количество и сумму всех чисел последовательности.

+5
Ответы (1)
  1. 13 мая, 09:51
    0
    Program klhj;

    var

    a, k, s: integer;

    begin

    a:=1;

    while a0 do

    begin

    write ('Введите число: ');

    readln (a);

    if a0 then

    begin

    k:=k+1;

    s:=s+a

    end;

    end;

    writeln ('Количество введенных чилел: ', k);

    writeln ('Сумма всех введенных чисел равна: ', s);

    readln;

    end.

    Используем оператор цикла с предусловием, условие продолжения цикла - а0. Как только переменная а становится нулевой (с клавиатуры вводится 0), цикл сразу прекращает свою работу. Чтобы избежать получения нулевого количества кругов цикла, задается начальное значении а=1. Можно взять любое значение кроме 0.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем. (a=0 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы