Задать вопрос

Дано действительное число Х. Напишите программу для вычисления: Числа Х, округлённого до ближайшего целого Числа Х без дробных цифр

+2
Ответы (1)
  1. 6 июля, 20:45
    0
    program zz1;

    var a, x:real; / / задаем переменные действительного типа

    k:integer; / / задаем переменную целого типа

    begin

    write (' введите заданное действительное число x '); / / вводим число с клавиатуры

    read (x);

    a:=round (x); / / округляем до ближайшего целого

    k:=trunc (x); / / отделяем целую часть действительного числа

    writeln (' целая часть заданного действительного числа Х без дробных цифр = ', k); / / выводим ответ

    write (' Число Х, округленное до ближайшего целого действительное число = ', a);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано действительное число Х. Напишите программу для вычисления: Числа Х, округлённого до ближайшего целого Числа Х без дробных цифр ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Дано вещественное число x. Напишите программу, которая вычисляет целую часть числа x, округленную до ближайшего целого, и выводит на экран монитора результат. Информатика, 7 класс.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дано действительное число x и натуральное число n. Написать программу вычисления выражения x^2/1+x^3/2 + ... + x^n/n-1. В паскале
Ответы (1)
Дано трехзначное число. Напишите программу, которая опеределяет Есть ли среди цифр заданного целого трехзначного числа одинаковые
Ответы (1)