Задать вопрос

Вася очень любил играть в карты. Однажды он решил написать программу, которая за него будет выбирать правильный ход. Программу он составил, осталось только ее проверить. Для проверки он решил запустить программу для всех возможных перемешиваний колоды. Он знает, что для каждой колоды программа работает ровно одну секунду. Необходимо определить, сколько секунд будет работать проверка на всех возможных перемешиваниях колоды, если в колоде N карт.

+5
Ответы (1)
  1. 26 июня, 16:51
    0
    Запишем решение программы на языке Pascal ABC

    program z1;

    var

    n, i:longint;

    k:comp;

    begin

    assign (input,'input. txt');

    reset (input);

    assign (output,'output. txt');

    rewrite (output);

    read (n);

    k:=1;

    for i:=1 to n do

    k:=k*i;

    writeln (k:0:0);

    close (input);

    close (output);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вася очень любил играть в карты. Однажды он решил написать программу, которая за него будет выбирать правильный ход. Программу он составил, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
В колоде содержится 48 карт. Из колоды случайным образом вытянули карту. Сколько информации несет сообщение о том, что вытянутая карта - туз?
Ответы (1)
Установите соответствие: 1) базовое системное ПО а) операционная система 2) утилиты б) программа диагностики дисков в) антивирусная программа г) операционная оболочка д) программа архивации данных e) программа обслуживания сети
Ответы (1)
В колоде 36 карт. Сколько информации содержится в сообщении о том, какие 3 карты вытащены?
Ответы (1)
1. Файл размером 4 Мбайт передаётся через некоторое соединение за 100 секунд. Определите размер файла (в Кбайтах), который можно передать через это же соединение за 75 секунд. 2.
Ответы (1)
Веб-обозреватель (браузер), это: а) программа для просмотра веб-страниц; б) программа для обновления Windows; в) программа для интернет-чата; г) Microsoft InternetExplorer.
Ответы (1)