Задать вопрос
28 сентября, 15:49

Дан одномерный массив чисел. Найти количество элементов массива, равных заданному числу, и вывести их номера. Найти сумму элементов массива, принадлежащих промежутку от а до b. Отрицательные элементы массива возвести в квадрат.

+4
Ответы (1)
  1. 28 сентября, 17:33
    0
    program zz1;

    const n = 50; / / задаем количество элементов в массиве

    var i, s, k, a, b:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write (' введите заданное число ');

    read (s);

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21) - 10;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] = s then k:=k + 1;

    writeln (' элементов равных заданному = ', k); / / выводим ответ

    write (' введите а и b ');

    read (a, b);

    for i:=1 to n do

    if (m[i] >=a) and (m[i] < = b) then s:=s + m[i]; / / получаем сумму

    writeln (' сумма найденных элементов = ', s); / / выводим ответ

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] < 0 then m[i]:=sqr (m[i]); / / возводим в квадрат

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан одномерный массив чисел. Найти количество элементов массива, равных заданному числу, и вывести их номера. Найти сумму элементов ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)