Задать вопрос

Написать программу, которая проверяет, сколько раз введенное с клавиатуры число встречается в заданном массиве

+2
Ответы (1)
  1. 7 мая, 02:41
    0
    program zz1;

    const n = 50; / / задаем количество элементов в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write (' введите заданное число ');

    read (s);

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] = s then k:=k + 1;

    writeln (' элементов равных заданному = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая проверяет, сколько раз введенное с клавиатуры число встречается в заданном массиве ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу, которая проверяет, делятся ли на 3 (2,4) целое число, введенное с клавиатуры
Ответы (1)
Написать программу, которая проверяет, является ли целое число, введенное пользователем, простым. Программа Паскаль Цикл с пост условием
Ответы (1)
Написать программу, которая в одномерном массиве, заданном вводом с клавиатуры вычисляет среднее арифметическое массива без максимального и минимального элемента массива.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напишите программу, которая находит в массиве самую длинную цепочку одинаковых элементов. Программа должна вывести значение элемента, который встречается наибольшее число раз подряд, и длину этой цепочки.
Ответы (1)