Задать вопрос

Написать программу, которая проверяет, является ли целое число, введенное пользователем, простым. Программа Паскаль Цикл с пост условием

+1
Ответы (1)
  1. 5 июля, 18:09
    0
    program zz1;

    function Prost (a:longint) : boolean;

    var i:longint;

    f:boolean;

    begin

    if a < 2 then f:=false

    else

    begin

    f:=true;

    i:=2;

    while (i * i < = a) and f do / / пока счетчик меньше корня из числа и нет делителей

    if a mod i = 0 then f:=false / / если делитель, то не простое

    else i:=i + 1;

    end;

    Prost:=f;

    end;

    var n:integer;

    begin

    writeln ('Введите натуральное число n='); / / вводим с клавиатуры число

    readln (n);

    if Prost (n) then writeln ('Простое') / / выводим ответ

    else writeln ('Не простое');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая проверяет, является ли целое число, введенное пользователем, простым. Программа Паскаль Цикл с пост условием ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу, которая проверяет, делятся ли на 3 (2,4) целое число, введенное с клавиатуры
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1. Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке.
Ответы (1)
Программа в Паскаль Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения. Входные данные Входная строка содержит единственное вещественное число в диапазоне от 0 до 8.
Ответы (1)
Написать программу, которая проверяет, сколько раз введенное с клавиатуры число встречается в заданном массиве
Ответы (1)