Задать вопрос

1. В Древней Греции, говорят, была демократия. И все решали голосованием. По каждому вопросу гражданин, например, Афин мог проголосовать "за","против" или не голосовать вообще. Напишите программу, которая бы подсчитывала число голосов и выводила на экран сообщение о том, принято решение или отклонено. (Количество голосующих 10). 2. В массиве хранятся величины роста студентов (от 150 до 230 см). Определить, сколько человек смогут попасть в команду по баскетболу. Критерий отбора-минимальный рост 180 см. Примечание: Массив заполняется случайными числами. В начале программы его необходимо вывести

+1
Ответы (1)
  1. 21 февраля, 22:49
    0
    program zz1;

    var i, j, s1, s2, s3, k:integer;

    mas:array[1 ... 10] of integer;

    begin

    for i:=1 to 10 do / / вводим с клавиатуры исходные данные

    begin

    write ('введите голос ', i,'-го гражданина (0-не голосует, 1-за, 2-против) ');

    read (k);

    if k=0 then s1:=s1+1;

    if k=1 then s2:=s2+1;

    if k=2 then s3:=s3+1;

    end;

    if (s2>s3) and (s2>s1) then writeln (' решение принято ') else writeln (' решение не принято '); / / выводим ответ

    for i:=1 to 10 do / / вводим случайные числа в массив

    begin

    mas[i]:=random (81) + 150;

    write (mas[i],' ');

    if mas[i]>=180 then j:=j+1;

    end;

    writeln;

    write (' количество человек попавших в команду = ', j);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. В Древней Греции, говорят, была демократия. И все решали голосованием. По каждому вопросу гражданин, например, Афин мог проголосовать ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) напишите программу которая спрашивала бы название продукта и его цену. И затем на экран выводила фразу "Ваши расходы на покупки равны руб.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)