Задать вопрос

Имеется последовательность чисел a1, a2, ..., aN. Найти сумму первых из них, произведение которых не превышает заданного числа М. СИ++. #include #include #include

+2
Ответы (1)
  1. 9 апреля, 13:25
    0
    Pascal: {Имеется последовательность чисел a1, a2, ..., aN. Найти сумму первых из них (считая слева направо), произведение которых не превышает заданного числа М.} program lab6_2; const n=3; var a:array [1 ... n]of integer; i, sum, m, p:integer; b:real; begin cls; sum:=0; for i:=1 to n do begin writeln ('введите ', i,'-ый элемент массива'); read (a[i]); end; writeln ('Введите число M'); read (m); for i:=1 to n do p:=a[i]*a[i+1]; while p
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Имеется последовательность чисел a1, a2, ..., aN. Найти сумму первых из них, произведение которых не превышает заданного числа М. СИ++. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана последовательность целых положительных чисел. Найти произведение только тех чисел, которые больше заданного числа М. Если таких нет, то выдать сообщение об этом. Нужно решить в Паскале с помощью линейных массивов
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет максимальное число. программа получает на вход целые числа, количество введенных чисел неизвестно. последовательность числа заканчивается числом 0.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)
Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)