Задать вопрос

Определить значение переменной с после выполнения следующего фрагмента программы а=7 а=а - 4 b=-a c = - a+2*b

+1
Ответы (1)
  1. 3 февраля, 02:23
    0
    а = 7 - в данной строке программы переменной а присваивается значение 7;

    а = а - 4 - в данной строке программы значение переменной а уменьшается на 4, после чего значение переменной станет равно 7 - 4 = 3;

    b = - a - здесь переменной b присваивается значение а с противоположным знаком, так как а = 3, то b = - 3;

    c = - a + 2 * b - переменной с присваивается сумма двух слагаемых: а с противоположным знаком и увеличенное в 2 раза значение переменной b: - 3 + 2 * (-3) = - 3 - 6 = - 9.

    Ответ: с = - 9.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Определить значение переменной с после выполнения следующего фрагмента программы а=7 а=а - 4 b=-a c = - a+2*b ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)