Задать вопрос

Дан двумерный массив размером n*m заполненный случайным образом. получить одномерный массив, элементами которого являются сумма наименьшего и наибольшего элементов соответственной строки двумерного массива (в паскале)

+1
Ответы (1)
  1. 27 февраля, 05:06
    0
    program zz1;

    const n = 4;

    m = 7; / / задаем количество элементов в массиве

    var i, j, min, max:integer; / / задаем переменные целого типа

    b:array [1 ... n, 1 ... m] of integer;

    a:array [1 ... n] of integer;

    begin

    for i:=1 to n do

    for j:=1 to m do / / получаем числа и записываем их в массив

    b[i, j]:=random (10);

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to m do

    write (b[i, j]:4);

    writeln;

    end;

    min:=100000; max:=0;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    if b[i, j] < = min then min:=b[i, j];

    if b[i, j] > = max then max:=b[i, j];

    end;

    a[i]:=min + max;

    min:=100000; max:=0;

    end;

    writeln;

    for i:=1 to n do write (a[i]:4);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан двумерный массив размером n*m заполненный случайным образом. получить одномерный массив, элементами которого являются сумма наименьшего ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1. Дан двумерный массив. Найти сумму элементов этого массива. 2. В одномерном массиве сосчитать количество элементов равных 0 3. Дан двумерный массив. Найти произведение элементов каждого столбца.
Ответы (1)
Дан одномерный целочисленный массив состоящий из 10 элементов составьте программу определения значемния суммы наибольшего и наименьшего элементов этого массива массив заполнить любым способом
Ответы (1)