Задать вопрос
2 мая, 13:34

Создать массив. вычислить произведение элементов с четными индексами. элементы массива - случайные целые числа из отрезка (-10; 10) блок схема и паскаль.

+4
Ответы (1)
  1. 2 мая, 17:17
    0
    Pascal:

    Var a:array[1 ... 10] of integer;

    i, p:integer;

    begin

    p:=1;

    for i:=1 to 10 do begin

    a[i]:=random (-10,10);

    if not odd (i) then p*=a[i];

    write (a[i]:3);

    end;

    writeln;

    writeln (p);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Создать массив. вычислить произведение элементов с четными индексами. элементы массива - случайные целые числа из отрезка (-10; 10) блок ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные элементы. 3. Все элементы массива с четными номерами удвоить, с нечетными - уменьшить на 1.
Ответы (1)