Задать вопрос

Составить программу которая поставит максимальный элемент массива на первое место (массив из 10 целых случайных чисел)

+1
Ответы (1)
  1. 27 февраля, 19:06
    0
    program zz1;

    var mas:array[1 ... 10] of integer; / /заводим массив

    i, k1, k2, max:integer; //задаем переменные

    begin

    for i:=1 to 10 do / /записываем в массив десять случайных чисел

    mas[i]:=random (21);

    for i:=1 to 10 do

    write (mas[i],' '); / /выводим исходный массив

    writeln;

    max:=0; / /задаем начальное значение максимальному

    for i:=1 to 10 do

    if mas[i]>max then begin max:=mas[i]; k1:=i; end;

    k2:=mas[1]; mas[1]:=max; mas[k1]:=k2; / /ставим максимальный элемент на первое место

    for i:=1 to 10 do

    write (mas[i],' '); / /выводим полученный массив

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу которая поставит максимальный элемент массива на первое место (массив из 10 целых случайных чисел) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)