Задать вопрос
5 декабря, 08:54

Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль

+4
Ответы (1)
  1. 5 декабря, 09:52
    0
    program chisla;

    var

    i, ch: integer;

    a, c, d, b, s:byte;

    begin

    for i:=1000 to 9999 do begin

    s:=0; ch:=i;

    a:=ch mod 10;

    ch: = ch div 100;

    b: = ch mod 10;

    c: = ch div 100;

    d: = i div 1000;

    writeln (d);

    s:=a+c+d+b;

    if s<4 then begin

    writeln ('Числа сума цифр у которых меньше 4');

    writeln (i) end else break;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы