Задать вопрос

В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы. Ниже представлен рекомендуемый вид экрана во время работы программы: Введите в одной строке элементы массива (10 чисел) и нажмите - > 12 0 10 22 0 0 0 10 0 0 Общее количество осадков за 10 дней: 54

+3
Ответы (1)
  1. 27 ноября, 23:09
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write (' Введите в одной строке элементы массива (10 чисел) и нажмите - > ');

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    read (m[i]);

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    s:=s + m[i]; / / получаем сумму

    write (' Общее количество осадков за 10 дней = ', s); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) В массиве хранятся сведения о количестве осадков, выпавших за январь. Определить: а) Общее количество осадков за январь;
Ответы (1)
Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)