Задать вопрос

Дано натуральное число N. Если число содержит 5 цифр, то получить новое число M, которое образуется путем исключения средней цифры исходного числа. Если количество цифр не 5, то M=N. P. S - решить без использования строковой переменной.

+1
Ответы (1)
  1. 8 ноября, 08:30
    0
    Uses crt; var n, m:integer; begin readln (n); if n div 1000>=10 then m: = (n div 10000) * 1000 + ((n div 1000) mod 10) * 100 + ((n div 10) mod 10) * 10 + (n mod 10) else m:=n; writeln (m); end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число N. Если число содержит 5 цифр, то получить новое число M, которое образуется путем исключения средней цифры ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Запишите на алгоритмическом языке алгоритм, в результате которого переменной а будет присвоено значение переменной Ь, переменной b - значение переменной с, а переменной с - значение переменной а. Используйте не более одной промежуточной переменной.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)
1. какие команды присваивания составлены правильно? a) A: = В б) А=В в) А=B+1 г) А+1:=А 2. Сколько промежуточных переменных потребуется для того, чтобы переменной А было присвоено значение переменной В, переменной В - значение переменной С, а
Ответы (1)
Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч). Используя текстовые файлы input, output.
Ответы (1)