Задать вопрос

1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата. Например, 6*6 = 36, 5*5 = 25, 76*76=5776. Определить, является ли данное число автоморфным.

+4
Ответы (1)
  1. 18 марта, 11:12
    0
    1) program zz1;

    var a, k, i, s, n:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное k ');

    read (k);

    s:=k;

    a:=k;

    while k0 do

    begin

    k:=k div 10;

    n:=n + 1;

    end;

    for i:=1 to n do

    s:=s*10;

    writeln ('полученное новое число = ', s+a); / / выводим ответ

    end.

    2) program zz1;

    var a, k, i, s, n:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное k ');

    read (k);

    s:=1;

    a:=k;

    while k0 do

    begin

    k:=k div 10;

    n:=n + 1;

    end;

    for i:=1 to n do

    s:=s*10;

    if (a*a) mod s = a then write (' число автоморфное ') else write (' число не автоморфное '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дано число. Получить новое число с обратным значением цифр, где 0→9, 1→8, 2→7, 3→6, 4→5, а цифры 5, 6,7,8,9 не изменяются.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Дано натуральное число N. Если число содержит 5 цифр, то получить новое число M, которое образуется путем исключения средней цифры исходного числа. Если количество цифр не 5, то M=N. P. S - решить без использования строковой переменной.
Ответы (1)