Задать вопрос

Напишите программу, которая сортирует одномерный массив.

+2
Ответы (1)
  1. 2 апреля, 00:03
    0
    program zz1;

    const n = 10; / / задаем количество чисел в массиве

    var i, k, j, b:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51) + 150;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i : = 1 to n-1 do

    for j : = 1 to n-i do

    if m[j] > m[j+1] then begin

    b : = m[j];

    m[j] : = m[j+1];

    m[j+1] : = b

    end;

    for i:=1 to n do / / выводим отсортированный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая сортирует одномерный массив. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Напишите программу, которая сортирует массив, а затем находит максимальное из чисел, встречающихся в массиве несколько раз.
Ответы (1)
Ввести положительные и отрицательные элементы квадратной матрицы и перезаписать все положительные элементы в одномерный массив. Вывести одномерный массив.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)