Задать вопрос

Напишите программу для нахождения корней квадратного уравнения. Должно выходить три случая: 1. Есть один корень 2. Нету корней 3. Два корня

+5
Ответы (1)
  1. 13 мая, 13:57
    0
    program zz1;

    var a, b, c, d:real; / / задаем переменные не целого типа

    begin

    write ('введите первый коэффициент ');

    read (a);

    write ('введите второй коэффициент ');

    read (b);

    write ('введите третий коэффициент ');

    read (c);

    d:=b*b - 4 * a * c; / / рассчитываем дискриминант

    if d < 0 then write (' корней нет ');

    if d = 0 then write (' корень квадратного уравнения = ', - b/2 * a);

    if d > 0 then Write (' первый корень = ', - b + sqrt (d) / 2 * a, ' второй корень = ',-b - sqrt (d) / 2 * a); / / выводим ответ в зависимости от одного из трех условий

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу для нахождения корней квадратного уравнения. Должно выходить три случая: 1. Есть один корень 2. Нету корней 3. Два корня ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
1. Составте программу для нахождения граммов G в X унциях (1 унция = 28,35 грамма). Исходное количиство граммов задается с клавиатуры. 2. Напишите программу нахождения длин медиан m1, m2 и m3 треугольника по указанным формулам.
Ответы (1)
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)