Задать вопрос

напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer) : integer; var p, i:integer; begin p:=1; for i:=1 to n do p:=p*i; factorial:=p; end;

+3
Ответы (1)
  1. 29 мая, 19:07
    0
    Var n:integer;

    ch:char;

    function factorial (n:integer) : longint;

    var p, i:integer;

    begin

    p:=1;

    for i:=1 to n do p:=p*i;

    factorial:=p;

    end;

    begin

    write ('N = ');

    readln (n);

    writeln ('Factorial: ', factorial (n));

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer) : integer; var p, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы