Задать вопрос

Напишите программу которая считает количество чётных цифр введённого числа

+4
Ответы (1)
  1. 10 августа, 18:50
    0
    var

    a, b, s: integer; / / объявление переменных целочисленного типа.

    begin

    write ('Введите число:'); / / вывод строки на экран.

    read (a); / / считываем значение переменной, введенной с клавиатуры.

    while a > 0 do / / начало цикла.

    begin

    b : = a mod 10; / / определяем последнюю цифру справа в числе.

    if (b mod 2 = 0) then / / если цифра четная, то считаем сумму.

    s: = s + 1;

    a : = a div 10; / / удаляем последнюю справа цифру в числе.

    end;

    writeln ('Количество четных цифр введенного числа равно: ', s); / / вывод строки на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу которая считает количество чётных цифр введённого числа ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы