Задать вопрос

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры. Сделать для программы Паскаль! с помощью функций div и mod

+1
Ответы (1)
  1. 16 декабря, 11:33
    0
    program zz1;

    var s, n, k:integer; / / задаем переменные целого типа

    begin

    n:=random (1000) + 100; / / получаем случайное трехзначное число

    s:=100; / / задаем начальное значение для параметра деления

    while n > 0 do / / организуем цикл, пока в трехзначном числе есть цифры

    begin

    k:=n div s; / / получаем первую цифру трехзначного числа

    write (k, ', '); / / выводим ее на экран через запятую

    n:=n mod s; / / отбрасываем первую цифру трехзначного числа

    s: = s div 10; / / изменяем параметр деления

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Получить случайное трехзначное число и вывести через запятую все его отдельные цифры. Сделать для программы Паскаль! с помощью функций div ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
Чему будет равно значение переменной с в результате выполнения фрагмента программы а:=125; b:=25; с:=12; if a div 25=0 then if a mod 12=0 then ... c:=b div (a mod c) else c:=a div (b mod c) 1) 0; 2) 1; 3) 12; 4) 125.
Ответы (1)
Чему будет равно значение с переменной c в результате выполнения фрагмента программы a:=125; b:=25; c:=12; if a div 25=0 then if a mod 12=0 then c:=b div (a mod c) else c:=a div (b mod c) 1) 0; 2) 1; 3) 12; 4) 125
Ответы (2)