Задать вопрос

Это программирование, паскаль, нужно написать программу Дан одномерный массив A, состоящий из N элементов, N - заданное натуральное число. Если элементы массива составляют строго монотонную последовательность, то все положительные элементы массива заменить единицей, иначе оставить массив без изменения.

+5
Ответы (1)
  1. 23 октября, 05:58
    0
    Var / /начало программы;

    а:array[1 ... 100] of integer; / /переменные для цикла;

    i, n:integer; / /переменные целого типа;

    begin

    writeln ('Введите нужное количество элементов'); / /просим ввести элементы;

    read (n); / /запишем в переменную;

    writeln ('Введите элемент'); / /просим ввести элемент;

    for i:=1 to n do / /цикл;

    read (a[i]);

    for i:=1 to n do

    if (a[i]>0) then a[i]:=1; / /условие;

    for i:=1 to n do

    write (a[i],' '); / /вывод пользователю;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Это программирование, паскаль, нужно написать программу Дан одномерный массив A, состоящий из N элементов, N - заданное натуральное число. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Ввести положительные и отрицательные элементы квадратной матрицы и перезаписать все положительные элементы в одномерный массив. Вывести одномерный массив.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)