Задать вопрос

Дан массив целых чисел. Напечатать все четные элементы.

+3
Ответы (1)
  1. 25 августа, 08:35
    0
    program zz1;

    const n = 5; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменную целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    writeln (' Четные элементы: ');

    for i:=1 to n do

    if m[i] mod 2 = 0 then writeln (' ', m[i]); / / выводим ответ на экран через пробел

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив целых чисел. Напечатать все четные элементы. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные элементы. 3. Все элементы массива с четными номерами удвоить, с нечетными - уменьшить на 1.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)