Задать вопрос

Дан массив из 10 элементов, которые заполняются случайным образом. Найти: а) наименьший элемент б) сумму не положительных элементов в) произведение элементов, кратных 3.

+4
Ответы (1)
  1. 24 октября, 08:48
    0
    program zz1;

    const n = 14; / /задаем количество элементов в массиве

    var i, min, s, p:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (201) - 60;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    min:=1000000; / /задаем начальное значение для минимального элемента

    for i:=1 to n do / / организуем цикл, в котором переберем все числа массива

    if m[i] < min then min:=m[i]; / /проверяем, если число из массива меньше минимального, то записываем его в минимальное

    writeln (' наименьший элемент = ', min); / / выводим ответ

    for i:=1 to n do / / организуем цикл, в котором переберем все числа массива

    if m[i] < 0 then s:=s + m[i]; / /проверяем, если число из массива меньше нуля, то добавляем в сумму

    writeln (' сумма = ', s); / / выводим ответ

    p:=1;

    for i:=1 to n do

    if m[i] mod 3 = 0 then p:=p * m[i];

    writeln (' произведение = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из 10 элементов, которые заполняются случайным образом. Найти: а) наименьший элемент б) сумму не положительных элементов в) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)