Задать вопрос

Составьте программу поиска чаще всего встречающегося элемента массива С (М, М).

+3
Ответы (1)
  1. 16 августа, 14:25
    0
    program zz1;

    const

    m = 5; //задаем количество элементов в массиве

    var

    i, max1, k, j, p: integer; / / задаем переменные целого типа

    c: array [1 ... m, 1 ... m] of integer;

    h: array [1 ... m * m] of integer;

    begin

    for i : = 1 to m do / / записываем в массив числа случайным образом

    for j : = 1 to m do

    c[i, j] : = random (201);

    for i : = 1 to m do / /выводим массив на экран

    begin

    for j : = 1 to m do

    write (c[i, j]:5);

    writeln;

    end;

    writeln; / / переходим на новую строку для вывода ответа

    p : = 1;

    for i : = 1 to m do / / переписываем двумерный массив в одномерный

    for j : = 1 to m do

    begin

    h[p] : = c[i, j]; p : = p + 1;

    end;

    for i : = 1 to m * m do

    begin

    for j : = 1 to m * m do

    if h[j] = h[i] then k : = k + 1;

    if k > max1 then begin max1 : = k; p : = h[i]; end;

    k : = 0;

    end;

    writeln (' чаще других встречается элемент = ', p, ' количество найденных элементов = ', max1); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу поиска чаще всего встречающегося элемента массива С (М, М). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Дан массив A [1 ... 18, 1 ... n] и натуральное число n. Составить программу поиска наибольшего по модулю элемента массива, а также индекса этого элемента.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)
Войти
Задать вопрос