Задать вопрос
19 сентября, 11:17

Введите с клавиатуры два целых нечетных числа (первое больше второго). Выведите на экран последовательность нечетных чисел, расположенных между этими числами (паскаль)

+1
Ответы (1)
  1. 19 сентября, 13:09
    0
    var n1, n2, i: integer;

    begin

    write ('Ввод числа 1: '); readln (n1);

    while (n1 mod 2 1) or (n1 = 1) do

    begin

    write ('Число должно быть нечётным и больше 1. Повторите ввод: '); readln (n1);

    end;

    write ('Ввод числа 2: '); readln (n2);

    while (n2 > = n1) or (n2 mod 2 1) do

    begin

    write ('Число 2 должно быть меньше числа 1 и быть нечётным. Повторите ввод: '); readln (n2);

    end;

    write ('Последовательность нечётных чисел между ', n2,' и ', n1, ': ');

    for i:=n2 to n1 do

    if (i mod 2 = 1) then write (i, ' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Введите с клавиатуры два целых нечетных числа (первое больше второго). Выведите на экран последовательность нечетных чисел, расположенных ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Введите с клавиатуры два целых числа. Выведите на экран сумму чисел, разницу между числами, квадрат разности между числами, частное и остаток от деления первого числа на второе
Ответы (1)
Введите строку символов; определите и выведите на экран ее длину. выведите на экран первый и последний символ этой строки (через Паскаль)
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: А и В. Если числа не равны, то замените каждое из них большим и выведите результаты на экран. Если они равны, то найдите и выведите удвоенную сумму этих чисел.
Ответы (1)