Задать вопрос
13 апреля, 03:44

написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется случайным образом числами от 0 до 50.

+3
Ответы (1)
  1. 13 апреля, 04:42
    0
    program zz1;

    const n = 20; / / задаем количество элементов в массиве

    var i, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write ('введите к '); read (k);

    for i:=1 to n do / / получаем 12 чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=k to n-1 do

    m[i]:=m[i+1]; / / удаляем к-ый элемент

    for i:=1 to n-1 do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)