Задать вопрос

В каждом шкафу 9 полок, на каждой полке по 4 книги. Напишите программу, определяющую, в каком по номеру шкафу и на какой полке находится n-я книга. паскаль

+4
Ответы (1)
  1. 25 декабря, 10:40
    0
    var n, a, b:integer;

    begin

    write ('n = ');

    readln (n);

    a: = (n-1) div (9*4) + 1;

    b: = (n - (a-1) * 9*4-1) div 4+1;

    writeln ('Шкаф = ', a,' полка = ', b);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В каждом шкафу 9 полок, на каждой полке по 4 книги. Напишите программу, определяющую, в каком по номеру шкафу и на какой полке находится ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике