Задать вопрос

Помогите написать программу в паскале. Заполните массив из N элементов случайными числами в интервале [1, N] так, чтобы в массив обязательно вошли все числа от 1 до N (постройте случайную перестановку). Пример: Массив: 3 2 1 4 5

+5
Ответы (1)
  1. 9 сентября, 02:02
    0
    const nmax=100;

    var a:array[1 ... nmax] of integer;

    n, m, i, j, x:integer;

    f:boolean;

    begin

    randomize;

    repeat

    write ('Размер массива от 2 до ', nmax,' n=');

    read (n)

    until n in [2 ... nmax];

    m:=1;

    a[1]:=1+random (n+1);

    write (a[1]);

    for i:=2 to n do

    begin

    repeat

    f:=false;

    x:=1+random (n+1);

    for j:=1 to m do

    if a[j]=x then f:=true;

    until f=false;

    a[i]:=x;

    m:=m+1;

    write (a[i]:4);

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Помогите написать программу в паскале. Заполните массив из N элементов случайными числами в интервале [1, N] так, чтобы в массив ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Заполнить массив из 10 элементов случайными числами в интервале [0 ... 4] и вывести номера всех элементов, равных X. Пример работы программы: Исходный массив: 4 0 1 2 0 1 3 4 1 0 Что ищем? 0 A[2], A[5], A[10]
Ответы (1)
Написать в ПаскальМассив из 15 элементов заполнить случайными четными числами в интервале от - 25 до 70. Вывести полученный массив на экран в строчку. Найти сумму наибольшего и наименьшего элементов массива. (Использовать пузырьковую сортировку).
Ответы (1)