Задать вопрос

Определите количество четных элементов в последовательности, завершающейся числом 0. Само число 0, и все, что следует за ним, учитывать не нужно.

+5
Ответы (1)
  1. 18 апреля, 09:44
    0
    program zz1;

    var x, y:integer; / / задаем переменные целого типа

    begin

    read (x);

    while x 0 do / / организуем цикл, в котором будем вводить числа последовательности, пока не введем ноль

    begin

    if (x mod 2 = 0) then y:=y + 1; / / проверяем, если число последовательности четное, то добавляем его в сумму

    read (x); / / вводим с клавиатуры очередное число последовательности

    end;

    write (' количество четных чисел последовательности = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Определите количество четных элементов в последовательности, завершающейся числом 0. Само число 0, и все, что следует за ним, учитывать не ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Определите среднее арифметическое элементов последовательности, завершающейся числом 0. Число 0 в последовательность не входит. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел.
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
Дан массив из 10 элементов. 1. Найти сумму чётных элементов 2. Найти произведения элементов, стоящмх на нечетных местах 3. Найти количество элементов больше трех
Ответы (1)