Задать вопрос

Дано: a, b, c. Записать формулу для вычисления максимального значения среди этих чисел.

+5
Ответы (1)
  1. 13 июня, 05:43
    0
    program zz1;

    var a, b, c, d:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    if (a > b) and (a > c) then d:=a; / / проверяем на максимальное первое число

    if (b > a) and (b > c) then d:=b; / / проверяем на максимальное второе число

    if (c > b) and (c > a) then d:=c; / / проверяем на максимальное третье число

    write (' максимальное среди трех заданных чисел = ', d);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано: a, b, c. Записать формулу для вычисления максимального значения среди этих чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Задан одномерный массив целых чисел. Вычислить сумму значений элементов, значения которых меньше половины значения максимального элемента чисел, но больше половины минимального элемента.
Ответы (1)
Составить программу для вычисления площади треугольника с координатами вершин (x1, y1), (x2, y2), (x3, y3), используя формулу для вычисления расстояния между двумя точками на плоскости. Площадь вычисляется по формуле Герона
Ответы (1)
Даны натуральное число x и целые числа a₁, a₂, ..., aₓ. Найти: а) номер максимального из чисел aₓ. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел aₓ.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)