Задать вопрос

Дано трехзначное число. Найти число единиц в нем, число десятков в нем, число сотен в нем, сумму его цифр, произведение его цифр

+2
Ответы (1)
  1. 6 марта, 02:09
    0
    2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 program z; uses crt; var s, p, b, a, a1, k, k1:integer; c:array [1 ... 100] of integer; begin clrscr; writeln ('Введите число'); readln (b); a:=b; p:=1; s:=0; k:=0; while a0 do begin a1:=a mod 10; k:=k+1; c[k]:=a1; s:=s+a1; p:=p*a1; a1:=a div 10; a:=a1; end; writeln ('Сумма цифр числа ', b,' - ', s); writeln ('Произведения цифр числа ', b,' - ', p); writeln ('Число единиц в числе ', b,' - ', c[1]); if k>1 then writeln ('Число десятков в числе ', b,' - ', c[2]) else writeln ('В числе ', b,' нет десятков!'); readln; end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано трехзначное число. Найти число единиц в нем, число десятков в нем, число сотен в нем, сумму его цифр, произведение его цифр ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Автомат принимает трёхзначное число, вычисляет сумму двух старших разрядов (сотен и десятков), а также сумму двух младших разрядов (десятков и единиц). Затем эти суммы выводятся на экран в порядке убывания (без пробелов).
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)
Дано трехзначное число определить является ли сумма его цифр двухзначным числом, является ли произведение его чисел трехзначным числом, кратно ли сумма его цифр числу 3
Ответы (1)