Задать вопрос

Составить программу к решению задачи : "дано число n. Найти сумму и количество его цифр.

+1
Ответы (1)
  1. 7 ноября, 07:16
    0
    program zz1;

    var i, b, n, s:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное число ');

    read (n); / / вводим с клавиатуры заданное число

    i:=0;

    while n>0 do / / организуем цикл, пока в числе есть цифры

    begin

    b:=n mod 10; / / получаем последнюю цифру

    s:=s+b; / / прибавляем последнюю цифру к сумме

    n:=n div 10; / / отбрасываем последнюю цифру из числа

    i:=i+1; / / считаем количество цифр

    end;

    writeln (' сумма цифр заданного числа = ', s);

    write (' количество цифр в заданном числе = ', i); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу к решению задачи : "дано число n. Найти сумму и количество его цифр. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано трехзначное число. Найти число единиц в нем, число десятков в нем, число сотен в нем, сумму его цифр, произведение его цифр
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!
Ответы (1)