Задать вопрос

составить алгоритм вычисления расстояния между 2 точками задаными на плоскости их координатами

+3
Ответы (1)
  1. 5 марта, 16:04
    0
    program zz1;

    var x1, x2, y1, y2, r:real; / /задаем переменные не целого типа

    begin

    write ('введите координаты первой точки '); / /вводим с клавиатуры координаты первой точки

    read (x1, y1);

    write ('введите координаты второй точки '); / /вводим с клавиатуры координаты второй точки

    read (x2, y2);

    r:=sqrt (sqr (x1-x2) + sqr (y1-y2)); / /вычисляем расстояние между точками по формуле

    write ('расстояние между точками, заданными координатами = ', r:5:2); / /выводим ответ в формате пять знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «составить алгоритм вычисления расстояния между 2 точками задаными на плоскости их координатами ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить программу для вычисления площади треугольника с координатами вершин (x1, y1), (x2, y2), (x3, y3), используя формулу для вычисления расстояния между двумя точками на плоскости. Площадь вычисляется по формуле Герона
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнять команду Сместиться на (a, b) (где a, b - целые числа), перемещающую Чертёжника из точки с координатами (x, y), в точку с координатами
Ответы (1)
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)