Задать вопрос

Составить алгоритм и программу для вычисления суммы чисел: 3,7,11,15 ...,87.

+5
Ответы (1)
  1. 5 июня, 13:38
    0
    program zz1;

    var i, s:integer; / / задаем переменные целого типа

    begin

    i:=3; / / задаем начальное значение числа ряда

    while i < = 87 do / / организуем цикл, в котором переберем все числа заданного ряда от трех до восьмидесяти семи

    begin

    s:=s + i; / / число ряда прибавляем к сумме

    i:=i + 4; / / из условия задачи стало понятно, что каждое следующее число отличается от предыдущего на четыре, исходя из этого получаем следующее число из ряда

    end;

    write (' полученная сумма чисел ряда = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм и программу для вычисления суммы чисел: 3,7,11,15 ...,87. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Напишите программу в Паскале.
Ответы (1)
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Разработать алгоритм и составить программу вычисления значений суммы S заданного ряда при различных значениях аргумента Х: во внутреннем цикле для фиксированного значения Х поочередно суммировать члены ряда, пока их абсолютная величина превышает
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)