Задать вопрос

Дана геометрическая прогрессия 3, 6, 12, 24, ... Чему будет равна сумма 13-ти ее членов? (составить программу в паскале+по возможности с блок-схемой)

+4
Ответы (1)
  1. 9 июля, 17:57
    0
    program zz1;

    var n, i, s:integer; / / задаем переменную целого типа

    begin

    n: = 3; / / задаем первый член геометрической прогрессии

    for i:=1 to 13 do / / организуем цикл на тринадцать повторений

    begin

    write (n,' ');

    s:=s + n; / / получаем сумму, добавляя к ней очередной член геометрической прогрессии

    n:=n * 2; / / получаем следующий член геометрической прогрессии

    end;

    writeln; / / переходим на новую строку для вывода ответа

    write (' сумма тринадцати членов геометрической прогрессии = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана геометрическая прогрессия 3, 6, 12, 24, ... Чему будет равна сумма 13-ти ее членов? (составить программу в паскале+по возможности с ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Определите значения переменных х и у после выполнения фрагмента алгоритма. а) блок-схема х у х у 15 5 12 4 б) блок-схема х у х у 3 16 9 5 в) блок-схема х у х у - 3 - 2 - 1 4
Ответы (1)
Вспомните пословицы, которые можно записать в виде следующих блок-схем. 1) блок-схема 2) блок-схема
Ответы (1)
В паскале Составить блок-схему и программу для вычисления значения функции Y при заданном значении аргумента x. y=4x^2+2 (x^2+1); x=3
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)