Задать вопрос

Составить программу, которая будет вычислять сумму чисел, введенных с терминала, до тех пор, пока сумма не станет больше 30.

+1
Ответы (1)
  1. 12 января, 20:53
    0
    program zz1;

    var n, s:integer; / / задаем переменные целого типа

    begin

    s:=0; / / задаем начальное значение суммы

    while s < = 30 do / / организуем цикл, пока сумма не станет больше тридцати

    begin

    read (n); / / вводим с терминала очередное число

    s:=s + n; / / прибавляем введенное число к сумме

    end;

    write (' полученная сумма чисел = ', s); / / выводим ответ на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая будет вычислять сумму чисел, введенных с терминала, до тех пор, пока сумма не станет больше 30. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0)
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Написать программу ввода массива до тех пор, пока сумма введенных элементов не превысит числа 100. На Паскале
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
С клавиатуры пользователь вводит числа до тех пор, пока не будет введен 0. вычислите сумму введенных чисел
Ответы (1)