Задать вопрос

Re: составьте программу вычисления среднего арифметического целых чисел из отрезка [-4; 15]

+4
Ответы (1)
  1. 14 апреля, 09:05
    0
    var i, n: integer; sr: real; / / так как среднее арифметическое не всегда является целым числом, то отнесём данную переменную к типу real.

    begin

    n : = 0;

    sr : = 0;

    for i : = - 4 to 15 do

    begin

    n : = n + 1;

    sr : = sr + i;

    end;

    sr : = sr / n;

    writeln ('Среднее арифметическое целых чисел из отрезка [-4; 15] равно ', sr, '.');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Re: составьте программу вычисления среднего арифметического целых чисел из отрезка [-4; 15] ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров, в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
Составьте программу вычисления среднего арифметического целых чисел из отрезка [-4; 15] (в python)
Ответы (1)
Составьте программу вычисления среднего арифметического целых чисел из отрезка [-4; 15]. (паскаль)
Ответы (1)
Написать на языке паскаль программу ввода четырех целых чисел и вычисления их среднего арифметического. протестировать программу на различных исходных данных и доказать правильность ее работы
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)