Задать вопрос

Составьте программу обмена значениями двух переменных величин: по следующей схеме: в-присвоить значение с а-присвоить значение в

+5
Ответы (1)
  1. 20 февраля, 20:46
    0
    Составим программу обмена значениями двух переменных величин:

    Program 1;

    Var a, b, c: integer;

    begin

    writeln ('введите значение переменной a ');

    readln (a);

    writeln ('ведите значение переменной b ');

    readln (b);

    c: = a;

    a: = b;

    b: = c;

    writeln ('Полученное значение a = ', a);

    writeln ('Полученное значение b = ', b);

    end.

    Проверим работу программы последовательно пройдясь по коду:

    Вводим с клавиатуры неизвестные переменные a и b:

    a = 5;

    b = 7;

    Переходим к обмену:

    с = 5;

    a = 7;

    b = 5;

    На экран выводится следующее:

    a = 7;

    b = 5.

    Таким образом произошел обмен переменных.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу обмена значениями двух переменных величин: по следующей схеме: в-присвоить значение с а-присвоить значение в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a, b, c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и вычисляет произведение элементов массива с чётными значениями и среднее арифм. элементов массива с нечётными значениями
Ответы (1)
Соотнесите: 1. сильная типизация 2. статическая типизация 3. явная типизация 4. динамическая типизация 5. слабая типизация 6. неявная типизация А. Типы переменных должны быть указаны в коде программы Б.
Ответы (1)
Вводятся величины X, Y целого типа. Написать программу для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать программу для X=5 и Y=-11.
Ответы (1)