Задать вопрос

Дано натуральное число N. Вычислить произведение первых N сомножителей. P = 2/3*4/5*6/7 * ... * 2N/2N+1

+4
Ответы (1)
  1. 16 августа, 23:12
    0
    program product_;

    var n: integer; / /число множителей

    p: real; / /переменная для результата произведения

    begin

    writeln ('Введите число множителей n');

    readln (n);

    p : = 1;

    write ('Результат умножения:');

    for i:integer : = 1 to n do

    p : = p * ((2 * i) / (2 * i + 1));

    writeln (p : 6 : 6) / /вывод результата

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число N. Вычислить произведение первых N сомножителей. P = 2/3*4/5*6/7 * ... * 2N/2N+1 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Число 12 можно записать в виде произведения простых множителей тремя способами: 12 = 2 * 2 * 3, 12 = 2 * 3 * 2, 12 = 3 * 2 * 2. А сколькими способами можно записать в виде произведения простых сомножителей число 52500?
Ответы (1)