Задать вопрос

заполнить двумерный массив NxN случайными числами из интервала [-10; 10], найти максимальный элемент в массиве и удалить строку, в которой находится этот элемент

+4
Ответы (1)
  1. 21 августа, 16:37
    0
    program example;

    const n=6;

    var

    a:array[1 ... n, 1 ... n] of integer;

    i, j, max, stroka:integer;

    begin

    randomize;

    max:=-10;

    stroka:=1;

    writeln ('Сгенированная матрица:');

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (21) - 10;

    if max
    max:=a[i, j];

    stroka:=i;

    end;

    write (a[i, j],' ');

    end;

    writeln;

    end;

    writeln ('номер удаляемой строки-', stroka);

    for i:=stroka to n-1 do

    for j:=1 to n do

    a[i, j]:=a[i+1, j];

    writeln ('Матрица без строки:');

    for i:=1 to n-1 do

    begin

    for j:=1 to n do begin

    write (a[i, j],' ');

    end;

    writeln;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «заполнить двумерный массив NxN случайными числами из интервала [-10; 10], найти максимальный элемент в массиве и удалить строку, в которой ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Заполнить двумерный массив NxN случайными числами из интервала [-5; 5] и найти максимальный элемент в каждой строке и поменять его первым элементом этой же строки
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
Заполнить массив случайными целыми числами. Найдите максимальный элемент в массиве
Ответы (1)
1. Дан двумерный массив. Найти сумму элементов этого массива. 2. В одномерном массиве сосчитать количество элементов равных 0 3. Дан двумерный массив. Найти произведение элементов каждого столбца.
Ответы (1)