Задать вопрос

Составить алгоритм нахождения диагонали прямоугольника если известны его стороны

+4
Ответы (1)
  1. program zz1;

    var a, b, c, S:real; / / задаем переменные не целого типа

    begin

    write ('введите первую сторону прямоугольника '); / / вводим с клавиатуры исходное значение первой стороны прямоугольника

    read (a);

    write ('введите вторую сторону прямоугольника '); / / вводим с клавиатуры исходное значение второй стороны прямоугольника

    read (b);

    c: = sqrt (sqr (a) + sqr (b)); / / вычисляем диагональ прямоугольника по формуле Пифагора

    write ('диагональ прямоугольника = ', c:5:2); / / выводим ответ в формате пять знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм нахождения диагонали прямоугольника если известны его стороны ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить алгоритм нахождения НОД трех натуральных чисел, используя вспомогательный алгоритм нахождения НОД двух чисел.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм) ?
Ответы (1)
Написать алгоритм: Даны 2 числа a и b оба вводятся с клавиатуры, написать алгоритм нахождения наибольшего из них
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)