Войти
Задать вопрос
Виктория Моисеева
Информатика
11 ноября, 12:50
найти сумму всех целых чисел от A до B.
+2
Ответы (
1
)
Ксения Дмитриева
11 ноября, 14:24
0
program zz1;
var a, b, r, i:integer; / / задаем переменные целого типа
begin
write (' введите первое число '); / / вводим с клавиатуры первое число
read (a);
write (' введите второе число '); / / вводим с клавиатуры второе число
read (b);
for i:=a to b do / / организуем цикл, в котором переберем все числа от а до b
r:=r + i; / / вычисляем сумму чисел от а до b по формуле
write (' сумма чисел от ', a,' до ', b,' = ', r); / / выводим ответ
end.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆
«найти сумму всех целых чисел от A до B. ...»
по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
Нужен ответ
Из данных слов Выпиши имена существительные сильный зима, найти, дерево, рисовать, красивый, воробей, река, ручной, решать, подснежник, показаться.
Нет ответа
В санатории привезли апельсины мандарины и лимоны апельсины составляет пять четырнадцатых всех фруктов мандарины восемь 21-й, а лимоны остальные 99 кг сколько килограммов фруктов привезли в санаторий
Нет ответа
Расположите числа 5,28; - 1,634; - 1,34; - 1, (3); 2,3 (4) и 2, (34) в порядке убывания
Нет ответа
сравнить природные условия финикии древнего египта и индии
Нет ответа
Расстояние между двумя пунктами 40 км. Из одного из них в другой одновременно въезжают автобус и велосипедист. Скорость автобуса 50 км в час, велосипедиста 10 км в час.
Нет ответа
Главная
»
Информатика
» найти сумму всех целых чисел от A до B.
Войти
Регистрация
Забыл пароль