Задать вопрос

Дано число n. Создайте массив A[2*n+1][2*n+1] и заполните его по спирали, начиная с числа 0 в центральной клетке A[n+1][n+1]. Спираль выходит вверх, далее закручивается против часовой стрелки. Входные данные Программа получает на вход одно число n. Выходные данные Программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. Примеры входные данные 2 выходные данные 12 11 10 9 24 13 2 1 8 23 14 3 0 7 22 15 4 5 6 21 16 17 18 19 20

+4
Ответы (1)
  1. 17 декабря, 15:12
    0
    var A:array[1 ... 100,1 ... 100] of Integer;

    x, k, j, i, N:integer;

    procedure up (i, o:integer);

    begin

    for o:=1 to i do

    begin

    x:=x+1;

    k:=k-1;

    A[k, j]:=x;

    end;

    end;

    procedure left (i, o:integer);

    begin

    for o:=1 to i do

    begin

    x:=x+1;

    j:=j-1;

    A[k, j]:=x;

    end;

    end;

    procedure down (i, o:integer);

    begin

    for o:=1 to i do

    begin

    x:=x+1;

    k:=k+1;

    A[k, j]:=x;

    end;

    end;

    procedure right (i, o:integer);

    begin

    for o:=1 to i do

    begin

    x:=x+1;

    j:=j+1;

    A[k, j]:=x;

    end;

    end;

    begin

    Readln (N);

    k:=n+1;

    j:=n+1;

    A[n+1, n+1]:=0;

    For i:=1 to 2*n do

    If i mod 2=1 then

    begin

    up (i, i);

    left (i, i);

    end

    else

    begin

    down (i, i);

    right (i, i);

    If i=2*n then

    up (i, i);

    end;

    For i:=1 to 2*n+1 do

    begin

    For j:=1 to 2*n+1 do

    Write (A[i, j],' ');

    Writeln;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано число n. Создайте массив A[2*n+1][2*n+1] и заполните его по спирали, начиная с числа 0 в центральной клетке A[n+1][n+1]. Спираль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
По данному натуральному n вычислите сумму 12+22 + ... + n2. Входные данные Вводится единственное натуральное число n, не превосходящее 100 Выходные данные Необходимо вывести вычисленную сумму. Примеры входные данные 2 выходные данные 5
Ответы (1)
Дано натуральное число. Выведите его последнюю цифру. Входные данные Вводится единственное число (гарантируется, что оно не превышает 10000). Выходные данные Выведите ответ на задачу. Примеры входные данные 249 выходные данные 9
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)