Задать вопрос

напишите процедуру, которая выведет на экран в столбик все цифры переданного ей числа, начиная с первой нужно полностью написать программу

+5
Ответы (1)
  1. 19 декабря, 22:25
    0
    var

    a : integer; / / объявляем переменную целочисленного типа.

    Procedure P1 (a:integer); / /начало процедуры.

    var

    i : integer; / / объявляем переменную целочисленного типа.

    s : string; / / объявляем переменную строкового типа.

    begin

    s:=inttostr (a); / / преобразуем число в строку.

    for i : = 1 to length (s) do / / начало цикла.

    writeln (s[i]); / / вывод каждой цифры на экран.

    end;

    begin / / начало основной программы.

    writeln ('Введите произвольное число:'); / /вывод строки на экран.

    read (a); / / считываем число, введенное с клавиатуры.

    P1 (a); / / вызов процедуры с параметром.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «напишите процедуру, которая выведет на экран в столбик все цифры переданного ей числа, начиная с первой нужно полностью написать программу ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы