Задать вопрос

Бэтмен считал день удачным, если ему удавалось совершить подвиг, и неудачным, если его помощь была в этот день не нужна. Супергерой вёл дневник, в котором отмечал каждый день либо У (удачный), либо Н (неудачный). По строке, содержащей символы У и Н, определите самую длинную последовательность из удачных дней.

+3
Ответы (1)
  1. 14 марта, 11:39
    0
    program luck;

    var s: string;

    max, k: integer;

    begin

    writeln ('Введите строку состоящую из букв У (Удачный) и Н (Неудачный) ');

    readln (s);

    max: = 0;

    for i: integer: = 1 to length (s) do

    begin

    if s[i] = 'У' then

    begin

    k: = k + 1;

    if k > max then max: = k

    end

    else k: = 0

    end;

    writeln ('Максимальное количество, подряд идущих удачных дней: ', max)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Бэтмен считал день удачным, если ему удавалось совершить подвиг, и неудачным, если его помощь была в этот день не нужна. Супергерой вёл ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая находит в массиве самую длинную цепочку одинаковых элементов. Программа должна вывести значение элемента, который встречается наибольшее число раз подряд, и длину этой цепочки.
Ответы (1)
18) Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов, в которых также могут встречаться следующие символы: Символ "?
Ответы (1)
Введите с клавиатуры одномерный числовой массив из 9 элементов. Сверните его в матрицу размером 3x3, разместив первую тройку элементов в 1-й строке матрицы, 2-ю тройку - во второй строке, 3-ю тройку - в третьей строке.
Ответы (1)
Текст рассказа набран на компьтере. Информацинный объём получившегося файла 15 Кбайт. Текст занимает 10 страниц, на каждой странице одинаковое количество строк, в каждый строке 64 символа. Все символы в кодировке unicode.
Ответы (1)
Дано предложение. Напечатать все символы, расположенные между 1 и 2 запятой. Если 2 запятой нет, то должны быть напечатаны все символы, расположенные после единственной запятой.
Ответы (1)