Задать вопрос

В бригаде, работающей на уборке сена, имеется N косилок. Первая из них работала M часов, а каждая следующая на 10 минут больше, чем предыдущая. Сколько часов проработала вся бригада?

+3
Ответы (1)
  1. 14 августа, 15:22
    0
    Время работы, как сумма арифметической прогрессии:

    а₁ = M, d = 10 мин = 1/6 часа.

    Сумма первых N членов арифметической прогрессии:

    S = ((2M + (N - 1) / 6) * N) / 2;

    Программа с использованием готовой формулы и добавлением времени в цикле:

    program senokos;

    var M, N: integer;

    s, s1: real;

    begin

    writeln ('Время работы первой косилки (M) ');

    readln (M);

    writeln ('Число коcилок (N) ');

    readln (N);

    S : = M;

    S : = ((2 * M + (N-1) / 6) * N) / 2;

    writeln ('Время работы бригады в часах (формула) - ', s);

    S : = M;

    S1: = M;

    For i: integer : = 1 to N - 1 do

    begin

    S : = S + 1/6;

    S1 : = S1 + S;

    end;

    writeln ('Время работы бригады в часах (цикл) - ', S1)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В бригаде, работающей на уборке сена, имеется N косилок. Первая из них работала M часов, а каждая следующая на 10 минут больше, чем ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
В начальный момент времени записана цифра 0. На каждом из следующих девяти шагов выполняются такие действия: в очередную строку записывается следующая по порядку цифра, после чего записывается предыдущая строка в обратном порядке.
Ответы (1)
Производительность одного рабочего на сборке мебели составляет N столов в час. Бригада состоит из М рабочих. Сколько столов соберёт вся бригада за Т часов? Написать программу в Паскале
Ответы (1)
Составить программу вычисления стоимости восьми книг, если одна книга стоит 100 рублей, а каждая следующая дороже предыдущей на 7 рублей. (паскаль)
Ответы (1)
Дано число n. С начала суток прошло n минут. Определите, сколько часов и минут будут показывать электронные часы в этот момент. Программа должна вывести два числа: количество часов (от 0 до 23) и количество минут (от 0 до 59).
Ответы (1)
Каждая бактерия делится на 2 через каждые 3 минуты. В начальный момент имеется 1 бактерия. Сколько их будет через n минут. N вводится пользователем. Составить программу с помощью цикла со счётчиком. (For счётчик:=нач.
Ответы (1)