Задать вопрос

Дан массив из 10 элементов. Определить среднее арифметическое элемента массива

+1
Ответы (1)
  1. 28 августа, 07:17
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    s:=s + m[i]; / / получаем сумму

    write (' среднее арифметическое элементов массива = ', s/n:5:2); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из 10 элементов. Определить среднее арифметическое элемента массива ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
Дан массив B, в котором содержится 10 элементов целого типа. Найти: А) сумму элементов этого массива Б) произведение элементов этого массива В) Среднее арифметическое этого массива Нужен алгоритм паскаль Например: Program Summa; Var B:array (1 ...
Ответы (1)
1. Составить программу, которая вводит с клавиатура массив из 5 целых чисел и выводит на экран значение четвертого элемента массива. 2. Дан массив из 10 элементов, заполненный удвоенными значениями индексов элементов массива.
Ответы (1)